.
Estadisticas ¿Karel? como instalar Uso Comandos Omijal Extras

Tumbando cabos

Descripción

Karel tiene problemas con la mafia italiana. Tiene que matar a los miembros de alto rango de
esta mafia.

Problema

Ayuda a karel a encontrar a los miembros de la mafia italiana(Mafiosos), asesinarlos y enterrarlos en su
casa para que no lo agarre la policia.

Consideraciones

• Karel inicia en la parte inferior izquierda (1,1).
• Karel termina en su casa sin importar su orientación.
• Karel no sabe donde están los mafiosos.
• Karel debe llevar a los mafiosos a su casa y enterrarlos.
• Las paredes del mundo pueden ser irregulares en el norte y el este.

Inicia en
y Termina
Ultimo fuente
Condiciones y ciclos, laborioso
2012-05-15 00:00:00 am Webmaster
iniciar-programa
    inicia-ejecucion
    mientras no orientado-al-norte hacer gira-izquierda;
    mientras frente-libre hacer
    inicio
      mientras frente-libre hacer
      inicio
        si junto-a-zumbador entonces coge-zumbador;
        si frente-libre entonces avanza;
      fin;
      si junto-a-zumbador entonces coge-zumbador;
      repetir 2 veces gira-izquierda;
      mientras frente-libre hacer avanza;
      gira-izquierda;
      si frente-libre entonces avanza;
      si frente-bloqueado y derecha-bloqueada entonces
      inicio
        mientras no orientado-al-sur hacer gira-izquierda;
        mientras frente-libre hacer avanza;
        repetir 3 veces gira-izquierda;
        mientras frente-libre hacer avanza;
        repetir 2 veces gira-izquierda;
        mientras frente-libre hacer
        inicio
          mientras frente-libre hacer
          inicio
            si junto-a-zumbador entonces coge-zumbador;
            si frente-libre entonces avanza;
          fin;
          repetir 2 veces gira-izquierda;
          si junto-a-zumbador entonces coge-zumbador;
          mientras frente-libre hacer avanza;
          repetir 3 veces gira-izquierda;
          si frente-libre entonces avanza;
          si frente-bloqueado y izquierda-bloqueada entonces
          inicio
            mientras no orientado-al-sur hacer gira-izquierda;
            mientras frente-libre hacer avanza;
            repetir 3 veces gira-izquierda;
            mientras frente-libre hacer avanza;
            mientras algun-zumbador-en-la-mochila hacer deja-zumbador;
            apagate;
          fin;
          repetir 3 veces gira-izquierda;
        fin;
      fin;
      gira-izquierda;
    fin;
        apagate;
    termina-ejecucion
finalizar-programa
Si desea donar:

Problemas

Atinale al Beeper...(5948)
01/08/2011
Beeper o Castigo...(3572)
01/08/2011
La maldicion de los Beepe...(3522)
01/08/2011
Diez Avenidas con Vallas...(3996)
01/08/2011
Dividiendo segmentos...(3202)
01/08/2011
Ve por Leña...(3945)
01/08/2011
Karel en una Callejoneada...(3663)
01/08/2011
Karel Traviesa...(3997)
01/08/2011
Karel y Gretel...(5348)
01/08/2011
Karel y Gretel en la Feri...(4391)
01/08/2011

Fuentes

Las Escaleras...(67)
19/04/2021
Diez Avenidas con Vallas...(30)
16/04/2021
Vigas...(80)
14/04/2020
Vigas...(61)
14/04/2020
La moneda...(593)
22/07/2017
Primer fuente...(456)
13/10/2012
Fuente las escaleras...(467)
16/05/2012
Fuente Tumbando cabos...(282)
15/05/2012
Fuente Repartiendo...(327)
15/05/2012
Fuente La Torre...(422)
15/05/2012

.: Publicidad :.