.
Estadisticas ¿Karel? como instalar Uso Comandos Omijal Extras

Baches

Descripción

Karel, como buen muchacho que es, ha decidido ir a ver a su abuela Karelita. Desafortunadamente, su abuela vive
muy lejos de su casa, y hay que pasar por caminos que tienen muchos baches (tantos que ya no se sabes cuál es
bache y cuál es la calle), pero lo que sí sabe es que la casa de su abuela está cuando encuentra un beeper en el
camino.

Problema

Debes hacer un programa que ayude a Karel a llegar a casa de su abuela, tomando en cuenta que el camino tiene
baches (agujeros de altura uno, pero anchura arbitraria). Además, debes de poner beepers a lo largo del camino
desde la posición inicial de Karel hasta la casa de la abuela.

Consideraciones

7. Karel comienza sobre la calle y mirando hacia el este.
8. La casa de la abuela nunca está en un bache.
9. Karel debe terminar en la posición del último beeper que marca el camino para la casa de la abuela.
10. El camino recorrido por Karel debe quedar marcado por montones de un beeper.
11. La edad de la abuela es de 105 años.
12. Nunca hay baches de más profundidad, ni escalones en todo el recorrido.
13. Nunca hay paredes sobre el camino que debes recorrer.

Inicia en
y Termina
Ultimo fuente
En este fuente contamos con Ciclos y condiciones
2012-04-29 00:00:00 am Leonardo
iniciar-programa
    inicia-ejecucion
    mientras no junto-a-zumbador hacer
    inicio
      si no junto-a-zumbador entonces deja-zumbador;
      mientras derecha-bloqueada hacer
      inicio
        avanza;
        si junto-a-zumbador entonces apagate; 
        deja-zumbador;
      fin;
      repetir 3 veces gira-izquierda;
      avanza;
      gira-izquierda;
      deja-zumbador;
      mientras derecha-bloqueada y frente-libre hacer
      inicio
        si frente-libre entonces avanza;
        si no junto-a-zumbador entonces deja-zumbador;
      fin;
      gira-izquierda;
      avanza;
      si no junto-a-zumbador entonces deja-zumbador;
      repetir 3 veces gira-izquierda;
      avanza;
    fin;
        apagate;
    termina-ejecucion
finalizar-programa
Si desea donar:

Problemas

Atinale al Beeper...(6040)
01/08/2011
Beeper o Castigo...(3620)
01/08/2011
La maldicion de los Beepe...(3581)
01/08/2011
Diez Avenidas con Vallas...(4081)
01/08/2011
Dividiendo segmentos...(3243)
01/08/2011
Ve por Leña...(4039)
01/08/2011
Karel en una Callejoneada...(3713)
01/08/2011
Karel Traviesa...(4061)
01/08/2011
Karel y Gretel...(5457)
01/08/2011
Karel y Gretel en la Feri...(4465)
01/08/2011

Fuentes

Las Escaleras...(71)
19/04/2021
Diez Avenidas con Vallas...(31)
16/04/2021
Vigas...(86)
14/04/2020
Vigas...(62)
14/04/2020
La moneda...(595)
22/07/2017
Primer fuente...(456)
13/10/2012
Fuente las escaleras...(468)
16/05/2012
Fuente Tumbando cabos...(282)
15/05/2012
Fuente Repartiendo...(329)
15/05/2012
Fuente La Torre...(423)
15/05/2012

.: Publicidad :.