.
Estadisticas ¿Karel? como instalar Uso Comandos Omijal Extras

El Estacionamiento

Descripción

Karel fue al supermercado para comprar más refrescos para la fiesta pero no encuentra lugar en el estacionamiento.

Problema

Ayuda a Karel a encontrar un lugar donde pueda estacionarse.

Consideraciones

• Karel inicia en su casa y orientado al norte.
• El mundo esta lleno de zumbadores a excepción de un lugar, en el cual se tiene que estacionar Karel.
• No importa hacia donde quede orientado Karel.
• El mundo es rectangular o cuadrado y no tiene obstáculos adentro.

Inicia en
y Termina
Ultimo fuente
Se emplea Condiciones y Ciclos
2012-04-29 00:00:00 am Leonardo
iniciar-programa
    inicia-ejecucion
    mientras junto-a-zumbador hacer
    inicio
      si frente-libre entonces avanza;
      si frente-bloqueado y junto-a-zumbador entonces
      inicio
        repetir 2 veces gira-izquierda;
        mientras frente-libre hacer avanza;
        gira-izquierda;
        avanza;
        gira-izquierda;
      fin;
    fin;
        apagate;
    termina-ejecucion
finalizar-programa
Si desea donar:

Problemas

Atinale al Beeper...(5832)
01/08/2011
Beeper o Castigo...(3515)
01/08/2011
La maldicion de los Beepe...(3353)
01/08/2011
Diez Avenidas con Vallas...(3938)
01/08/2011
Dividiendo segmentos...(3152)
01/08/2011
Ve por Leña...(3879)
01/08/2011
Karel en una Callejoneada...(3592)
01/08/2011
Karel Traviesa...(3940)
01/08/2011
Karel y Gretel...(5265)
01/08/2011
Karel y Gretel en la Feri...(4304)
01/08/2011

Fuentes

Las Escaleras...(64)
19/04/2021
Diez Avenidas con Vallas...(28)
16/04/2021
Vigas...(80)
14/04/2020
Vigas...(59)
14/04/2020
La moneda...(592)
22/07/2017
Primer fuente...(456)
13/10/2012
Fuente las escaleras...(466)
16/05/2012
Fuente Tumbando cabos...(282)
15/05/2012
Fuente Repartiendo...(327)
15/05/2012
Fuente La Torre...(420)
15/05/2012

.: Publicidad :.