.
Estadisticas ¿Karel? como instalar Uso Comandos Omijal Extras

La(s) Moneda(s)

Descripción

Este es una variante del problema anterior, ahora no sabemos cuántas monedas perdió Karel.

Problema

Karel cree que perdió monedas entre la tienda y su casa. Ayuda a Karel a encontrarlas.

Consideraciones

• Karel siempre empieza en su casa viendo hacia el este.
• No se sabe cuántas monedas perdió Karel.
• No se sabe la distancia de la tienda a su casa.
• Karel debe dejar las monedas en su casa.
• La tienda se encuentra en la misma fila que Karel.
• No existen obstáculos de por medio.
• Las monedas son representadas por zumbadores.
• Karel debe finalizar en su casa sin importar su orientación.
• Solo puede haber 1 zumbador máximo por posición

Inicia en
y Termina
Ultimo fuente
En este ejemplo estamos usando el mientras para que camine hasta topar con el muro y dentro del mismo recoge los zumbadores para luego regresar. Se podría considerar como diferencia en el de las monedas
2011-08-08 00:00:00 am Webmaster
iniciar-programa  
    inicia-ejecucion  
        mientras frente-libre hacer  
        inicio  
           si junto-a-zumbador entonces  
              coge-zumbador;   
           avanza  
        fin;   
        si junto-a-zumbador entonces  
           coge-zumbador;   
        gira-izquierda;   
        gira-izquierda;   
        mientras frente-libre hacer avanza;   
        deja-zumbador;   
        apagate;   
    termina-ejecucion  
finalizar-programa
Si desea donar:

Problemas

Atinale al Beeper...(6562)
01/08/2011
Beeper o Castigo...(3901)
01/08/2011
La maldicion de los Beepe...(3911)
01/08/2011
Diez Avenidas con Vallas...(4639)
01/08/2011
Dividiendo segmentos...(3510)
01/08/2011
Ve por Leña...(4419)
01/08/2011
Karel en una Callejoneada...(4012)
01/08/2011
Karel Traviesa...(4429)
01/08/2011
Karel y Gretel...(6066)
01/08/2011
Karel y Gretel en la Feri...(4883)
01/08/2011

Fuentes

Las Escaleras...(112)
19/04/2021
Diez Avenidas con Vallas...(47)
16/04/2021
Vigas...(117)
14/04/2020
Vigas...(80)
14/04/2020
La moneda...(621)
22/07/2017
Primer fuente...(459)
13/10/2012
Fuente las escaleras...(500)
16/05/2012
Fuente Tumbando cabos...(290)
15/05/2012
Fuente Repartiendo...(335)
15/05/2012
Fuente La Torre...(431)
15/05/2012

.: Publicidad :.