.
Estadisticas ¿Karel? como instalar Uso Comandos Omijal Extras

Secuestro Express

Descripción

Karel está enojado con Aldo, un compañero de clase, porque le volteó su mochila entonces ha planeado un secuestro.

Problema

Ayuda a Karel a secuestrar a Aldo para que aprenda de no meterse con él. Encuentra a Aldo y secuéstralo (rodéalo con zumbadores).

Consideraciones

• No se sabe donde inicia Karel.
• El mundo es rectangular o cuadrado y no tiene obstáculos adentro.
• No importa donde termine Karel.
• Aldo es representado por un montón de 2 zumbadores.
• Tienes que rodear a Aldo con montones de 1 zumbador.
• Aldo tiene fobia a las paredes por lo que nunca podrá estar pegado a ella.
• Karel tiene 8 zumbadores en la mochila.

Inicia en
y Termina
Ultimo fuente
Ciclos y condiciones, muy bueno para desarrollar la logica de programador
2012-05-03 00:00:00 am Leonardo
iniciar-programa
    inicia-ejecucion
    mientras no orientado-al-oeste hacer gira-izquierda;
    mientras frente-libre hacer avanza;
    gira-izquierda;
    mientras frente-libre hacer avanza;
    gira-izquierda;
    mientras frente-libre hacer
    inicio
      mientras frente-libre y no junto-a-zumbador hacer avanza;
      si junto-a-zumbador entonces
      inicio
        mientras no frente-bloqueado hacer gira-izquierda;
        si izquierda-bloqueada y frente-bloqueado entonces repetir 2 veces gira-izquierda;        
        si frente-bloqueado y derecha-bloqueada entonces
        inicio
          repetir 3 veces
          inicio
            gira-izquierda;
            avanza;
            deja-zumbador;
          fin;
          apagate;
        fin;
        si frente-bloqueado y derecha-libre y izquierda-libre entonces
        inicio
          gira-izquierda;
          avanza;
          gira-izquierda;
          repetir 2 veces
          inicio
            deja-zumbador;
            avanza;
            deja-zumbador;
            gira-izquierda;
            avanza;
          fin;
          deja-zumbador;
          apagate;
        fin;
        si frente-libre y derecha-libre y izquierda-libre entonces
        inicio
          gira-izquierda;
          avanza;
          gira-izquierda;
          repetir 4 veces
          inicio
            deja-zumbador;
            avanza;
            deja-zumbador;
            gira-izquierda;
            avanza;
          fin;
          deja-zumbador;
          apagate;
        fin;
      fin;
      si frente-bloqueado entonces
      inicio
        repetir 2 veces gira-izquierda;
        mientras frente-libre hacer avanza;
        repetir 3 veces gira-izquierda;
        avanza;
        repetir 3 veces gira-izquierda;
      fin;
    fin;
        apagate;
    termina-ejecucion
finalizar-programa
Si desea donar:

Problemas

Atinale al Beeper...(5948)
01/08/2011
Beeper o Castigo...(3572)
01/08/2011
La maldicion de los Beepe...(3523)
01/08/2011
Diez Avenidas con Vallas...(3996)
01/08/2011
Dividiendo segmentos...(3202)
01/08/2011
Ve por Leña...(3945)
01/08/2011
Karel en una Callejoneada...(3663)
01/08/2011
Karel Traviesa...(3997)
01/08/2011
Karel y Gretel...(5348)
01/08/2011
Karel y Gretel en la Feri...(4391)
01/08/2011

Fuentes

Las Escaleras...(67)
19/04/2021
Diez Avenidas con Vallas...(30)
16/04/2021
Vigas...(80)
14/04/2020
Vigas...(61)
14/04/2020
La moneda...(593)
22/07/2017
Primer fuente...(456)
13/10/2012
Fuente las escaleras...(467)
16/05/2012
Fuente Tumbando cabos...(282)
15/05/2012
Fuente Repartiendo...(327)
15/05/2012
Fuente La Torre...(422)
15/05/2012

.: Publicidad :.