.
Estadisticas ¿Karel? como instalar Uso Comandos Omijal Extras

El Globazo

Descripción

Karel y sus amigos han decidido ir a la fiesta de Karelandia y hacer travesuras a los paseantes. Karel debe encontrar
a su cómplice (zumbador 2), y cuando lo encuentre, aventara 4 globos de agua hacia el norte. La plaza principal
está llena de personas, entonces siempre mojará a 4 personas a menos que encuentre la pared.

Problema

Debes hacer un programa donde Karel encuentre a su cómplice y moje a 4 personas hacia el norte.

Consideraciones

1. Karel comienza sobre en algún lugar del mundo.
2. El cómplice es un montón de 2 zumbadores.
3. El mundo está lleno de zumbadores.
4. El mundo es rectangular o cuadrado y no tiene paredes adentro.
5. El cómplice lleva chamarra azul.
6. No importa la orientación final de Karel.

Inicia en
y Termina
Ultimo fuente
Se emplean Nuevas funciones, Ciclos y condiciones
2012-04-29 00:00:00 am Leonardo
iniciar-programa
define-nueva-instruccion revisar como
inicio
  coge-zumbador;
  si no junto-a-zumbador entonces
  inicio
    deja-zumbador;
    si frente-libre entonces avanza;
  fin
  sino
  inicio
    repetir 1 veces deja-zumbador;
    gira-izquierda;
    repetir 4 veces
    inicio
     si junto-a-zumbador entonces coge-zumbador;
     si frente-libre entonces avanza;
    fin;
    apagate;
  fin;
fin;
    inicia-ejecucion
  mientras no orientado-al-oeste hacer gira-izquierda;
  mientras frente-libre hacer avanza;
  gira-izquierda;
  mientras frente-libre hacer avanza;
  gira-izquierda;
  mientras frente-libre hacer
  inicio
    mientras frente-libre hacer
    inicio
      revisar;
    fin;
    revisar;
    repetir 2 veces gira-izquierda;
    mientras frente-libre hacer avanza;
    repetir 3 veces gira-izquierda;
    avanza;
    repetir 3 veces gira-izquierda;
  fin;
        apagate;
    termina-ejecucion
finalizar-programa
Si desea donar:

Problemas

Atinale al Beeper...(6040)
01/08/2011
Beeper o Castigo...(3619)
01/08/2011
La maldicion de los Beepe...(3580)
01/08/2011
Diez Avenidas con Vallas...(4080)
01/08/2011
Dividiendo segmentos...(3242)
01/08/2011
Ve por Leña...(4039)
01/08/2011
Karel en una Callejoneada...(3713)
01/08/2011
Karel Traviesa...(4061)
01/08/2011
Karel y Gretel...(5457)
01/08/2011
Karel y Gretel en la Feri...(4464)
01/08/2011

Fuentes

Las Escaleras...(71)
19/04/2021
Diez Avenidas con Vallas...(31)
16/04/2021
Vigas...(86)
14/04/2020
Vigas...(62)
14/04/2020
La moneda...(595)
22/07/2017
Primer fuente...(456)
13/10/2012
Fuente las escaleras...(468)
16/05/2012
Fuente Tumbando cabos...(282)
15/05/2012
Fuente Repartiendo...(329)
15/05/2012
Fuente La Torre...(423)
15/05/2012

.: Publicidad :.