.
Estadisticas ¿Karel? como instalar Uso Comandos Omijal Extras

Repartiendo

Descripción

Karel esta jugando con sus soldaditos y necesita hacer dos ejércitos que estén en opuestos lados
de su cuarto para poder hacer una guerra.

Problema

Ayuda a Karel a repartir los soldaditos en su cuarto.

Consideraciones

• Karel inicia encima del monton de soldaditos (zumbadores) en el centro de su cuarto.
• No existen obstáculos de por medio excepto las pareden que lo rodean.
• No importa donde termine Karel.
• Los soldaditos tienes que esta a los extremos del cuarto.
• Si Karel tiene un número impar de soldaditos, el montón de la izquierda tundra 1 más.

Inicia en
y Termina
Ultimo fuente
Ciclos y condiciones
2012-05-15 00:00:00 am Webmaster
iniciar-programa
    inicia-ejecucion
    mientras frente-libre o junto-a-zumbador hacer
    inicio
      gira-izquierda;
      si junto-a-zumbador entonces coge-zumbador;
      mientras frente-libre hacer avanza;
      si algun-zumbador-en-la-mochila entonces deja-zumbador sino apagate;
      repetir 2 veces gira-izquierda;
      avanza;
      mientras frente-libre y no junto-a-zumbador hacer avanza;
      si frente-bloqueado entonces apagate;
      repetir 3 veces gira-izquierda;
    fin;
        apagate;
    termina-ejecucion
finalizar-programa
Si desea donar:

Problemas

Atinale al Beeper...(6040)
01/08/2011
Beeper o Castigo...(3620)
01/08/2011
La maldicion de los Beepe...(3581)
01/08/2011
Diez Avenidas con Vallas...(4081)
01/08/2011
Dividiendo segmentos...(3243)
01/08/2011
Ve por Leña...(4039)
01/08/2011
Karel en una Callejoneada...(3713)
01/08/2011
Karel Traviesa...(4061)
01/08/2011
Karel y Gretel...(5457)
01/08/2011
Karel y Gretel en la Feri...(4465)
01/08/2011

Fuentes

Las Escaleras...(71)
19/04/2021
Diez Avenidas con Vallas...(31)
16/04/2021
Vigas...(86)
14/04/2020
Vigas...(62)
14/04/2020
La moneda...(595)
22/07/2017
Primer fuente...(456)
13/10/2012
Fuente las escaleras...(468)
16/05/2012
Fuente Tumbando cabos...(282)
15/05/2012
Fuente Repartiendo...(329)
15/05/2012
Fuente La Torre...(423)
15/05/2012

.: Publicidad :.