.
Estadisticas ¿Karel? como instalar Uso Comandos Omijal Extras

Repartiendo

Descripción

Karel esta jugando con sus soldaditos y necesita hacer dos ejércitos que estén en opuestos lados
de su cuarto para poder hacer una guerra.

Problema

Ayuda a Karel a repartir los soldaditos en su cuarto.

Consideraciones

• Karel inicia encima del monton de soldaditos (zumbadores) en el centro de su cuarto.
• No existen obstáculos de por medio excepto las pareden que lo rodean.
• No importa donde termine Karel.
• Los soldaditos tienes que esta a los extremos del cuarto.
• Si Karel tiene un número impar de soldaditos, el montón de la izquierda tundra 1 más.

Inicia en
y Termina
Ultimo fuente
Ciclos y condiciones
2012-05-15 00:00:00 am Webmaster
iniciar-programa
    inicia-ejecucion
    mientras frente-libre o junto-a-zumbador hacer
    inicio
      gira-izquierda;
      si junto-a-zumbador entonces coge-zumbador;
      mientras frente-libre hacer avanza;
      si algun-zumbador-en-la-mochila entonces deja-zumbador sino apagate;
      repetir 2 veces gira-izquierda;
      avanza;
      mientras frente-libre y no junto-a-zumbador hacer avanza;
      si frente-bloqueado entonces apagate;
      repetir 3 veces gira-izquierda;
    fin;
        apagate;
    termina-ejecucion
finalizar-programa
Si desea donar:

Problemas

Atinale al Beeper...(6261)
01/08/2011
Beeper o Castigo...(3727)
01/08/2011
La maldicion de los Beepe...(3695)
01/08/2011
Diez Avenidas con Vallas...(4286)
01/08/2011
Dividiendo segmentos...(3338)
01/08/2011
Ve por Leña...(4165)
01/08/2011
Karel en una Callejoneada...(3811)
01/08/2011
Karel Traviesa...(4204)
01/08/2011
Karel y Gretel...(5716)
01/08/2011
Karel y Gretel en la Feri...(4629)
01/08/2011

Fuentes

Las Escaleras...(88)
19/04/2021
Diez Avenidas con Vallas...(38)
16/04/2021
Vigas...(110)
14/04/2020
Vigas...(76)
14/04/2020
La moneda...(610)
22/07/2017
Primer fuente...(458)
13/10/2012
Fuente las escaleras...(473)
16/05/2012
Fuente Tumbando cabos...(284)
15/05/2012
Fuente Repartiendo...(334)
15/05/2012
Fuente La Torre...(428)
15/05/2012

.: Publicidad :.