.
Estadisticas ¿Karel? como instalar Uso Comandos Omijal Extras

La Cruz

Descripción

Karel tiene como misión encontrar la cruz en donde se encuentra un tesoro.

Problema

Ayuda a Karel a encontrar la cruz y posicionarse al centro de ella.

Consideraciones

• Karel inicia en la posición 1,1.
• El mundo es cuadrado y no se sabe que tan grande es.
• La cruz está representada con zumbadores.
• Karel debe terminar en el centro de la cruz sin importar su orientación.
• No importan los valores(zumbadores) de la cruz.

Inicia en
y Termina
Ultimo fuente
Ciclos, condiciones y nuevas intrucciones
2012-04-29 00:00:00 am Leonardo
iniciar-programa
define-nueva-instruccion rev como
inicio
  si frente-libre entonces
  inicio
    avanza;
    si junto-a-zumbador entonces
    inicio
      repetir 2 veces gira-izquierda;
      avanza;
      mientras no orientado-al-norte hacer gira-izquierda;
    fin
    sino
    inicio
      repetir 2 veces gira-izquierda;
      avanza;
      mientras no orientado-al-este hacer gira-izquierda;
    fin;
  fin
  sino
  mientras no orientado-al-este hacer gira-izquierda;
fin;
define-nueva-instruccion rev2 como
inicio
  gira-izquierda;
  rev
fin;
define-nueva-instruccion rev3 como
inicio
  gira-izquierda;
  rev2;
fin;
define-nueva-instruccion rev4 como
inicio
  gira-izquierda;
  rev3;
fin;
    inicia-ejecucion
    mientras no orientado-al-este hacer gira-izquierda;
    mientras frente-libre hacer
    inicio
      si no junto-a-zumbador entonces avanza;
      si junto-a-zumbador entonces
      inicio
        mientras no orientado-al-norte hacer gira-izquierda;
        rev;
        si orientado-al-norte entonces rev2;
        si orientado-al-norte entonces rev3;
        si orientado-al-norte entonces rev4;
        si orientado-al-norte entonces apagate;
        si orientado-al-este y frente-libre entonces avanza;
      fin;
      si frente-bloqueado entonces
      inicio
        repetir 2 veces gira-izquierda;
        mientras frente-libre hacer avanza;
        repetir 3 veces gira-izquierda;
        avanza;
        repetir 3 veces gira-izquierda;
      fin;
    fin;
        apagate;
    termina-ejecucion
finalizar-programa
Si desea donar:

Problemas

Atinale al Beeper...(6040)
01/08/2011
Beeper o Castigo...(3620)
01/08/2011
La maldicion de los Beepe...(3581)
01/08/2011
Diez Avenidas con Vallas...(4081)
01/08/2011
Dividiendo segmentos...(3243)
01/08/2011
Ve por Leña...(4039)
01/08/2011
Karel en una Callejoneada...(3713)
01/08/2011
Karel Traviesa...(4061)
01/08/2011
Karel y Gretel...(5457)
01/08/2011
Karel y Gretel en la Feri...(4465)
01/08/2011

Fuentes

Las Escaleras...(71)
19/04/2021
Diez Avenidas con Vallas...(31)
16/04/2021
Vigas...(86)
14/04/2020
Vigas...(62)
14/04/2020
La moneda...(595)
22/07/2017
Primer fuente...(456)
13/10/2012
Fuente las escaleras...(468)
16/05/2012
Fuente Tumbando cabos...(282)
15/05/2012
Fuente Repartiendo...(329)
15/05/2012
Fuente La Torre...(423)
15/05/2012

.: Publicidad :.