.
Estadisticas ¿Karel? como instalar Uso Comandos Omijal Extras

Las Escaleras

Descripción

A Karel se le cayó la cartera en las escaleras y necesita ir a recogerla.

Problema

Ayuda a Karel a encontrar su cartera que tiró en las escaleras.

Consideraciones

• Karel inicia en alguna parte del mundo orientado hacia las escaleras.
• La escalera inicia en la primera fila del mundo.
• La cartera esta en uno de los escalones.
• La cartera es representada por un zumbador.
• Karel no sabe cuantos escalones tiene la escalera.
• Karel termina en el principio de la escalera sin importar su orientación.

Inicia en
y Termina
Ultimo fuente
Las Escaleras, considerando varios mundos posibles
2021-04-19 10:40:21 am EmilioLeon24
iniciar-programa
  define-nueva-instruccion derecha como
    inicio
   repetir 3 veces
    gira-izquierda;
    fin;
      define-nueva-instruccion regresa como
      inicio
     mientras no-orientado-al-oeste hacer
       inicio
        gira-izquierda;
       fin;
     mientras izquierda-bloqueada hacer
         avanza;
        gira-izquierda;
      avanza;
      derecha;
    fin;
define-nueva-instruccion busca como
    inicio
       mientras frente-libre hacer
         avanza;
      si frente-bloqueado entonces
       si junto-a-zumbador entonces
           inicio
          mientras junto-a-zumbador hacer
              inicio
           coge-zumbador;
          fin;
           apagate;
          fin;
           gira-izquierda;
          avanza;
          derecha;
           avanza;
         mientras junto-a-zumbador hacer
           coge-zumbador;
         si ningun-zumbador-en-la-mochila entonces
           busca;
           si algun-zumbador-en-la-mochila entonces
            regresa;
         fin;
       inicia-ejecucion
         busca;
        apagate;
    termina-ejecucion
finalizar-programa
Si desea donar:

Problemas

Atinale al Beeper...(5832)
01/08/2011
Beeper o Castigo...(3515)
01/08/2011
La maldicion de los Beepe...(3353)
01/08/2011
Diez Avenidas con Vallas...(3938)
01/08/2011
Dividiendo segmentos...(3151)
01/08/2011
Ve por Leña...(3879)
01/08/2011
Karel en una Callejoneada...(3592)
01/08/2011
Karel Traviesa...(3940)
01/08/2011
Karel y Gretel...(5265)
01/08/2011
Karel y Gretel en la Feri...(4304)
01/08/2011

Fuentes

Las Escaleras...(64)
19/04/2021
Diez Avenidas con Vallas...(28)
16/04/2021
Vigas...(80)
14/04/2020
Vigas...(59)
14/04/2020
La moneda...(592)
22/07/2017
Primer fuente...(456)
13/10/2012
Fuente las escaleras...(466)
16/05/2012
Fuente Tumbando cabos...(282)
15/05/2012
Fuente Repartiendo...(327)
15/05/2012
Fuente La Torre...(420)
15/05/2012

.: Publicidad :.