.
Estadisticas ¿Karel? como instalar Uso Comandos Omijal Extras

LA TORRE

Descripción

Karel consiguió chamba como demoledor de edificios en la ciudad y su primer trabajo es tumbar
la torre más alta de la ciudad.

Problema

Ayuda a Karel a tirar la torre más alta del mundo.

Consideraciones

• No se sabe donde inicia Karel.
• El mundo es rectangular o cuadrado y no tiene obstáculos adentro.
• Karel termina en la base de la torre encima del montón de escombros.
• Si hay dos torres del mismo tamaño Karel tiene que tumbar la de la izquierda.

Inicia en
y Termina
Ultimo fuente
Ciclos y condiciones
2012-05-15 00:00:00 am Webmaster
iniciar-programa
    inicia-ejecucion
    mientras no orientado-al-norte hacer gira-izquierda;
    mientras frente-libre hacer avanza;
    mientras no orientado-al-oeste hacer gira-izquierda;
    mientras frente-libre hacer avanza;
    mientras no orientado-al-este hacer gira-izquierda;
    mientras no junto-a-zumbador hacer
    inicio
      mientras no junto-a-zumbador y frente-libre hacer avanza;
      si junto-a-zumbador entonces
      inicio
        repetir 3 veces gira-izquierda;
        mientras frente-libre hacer
        inicio
          coge-zumbador;
          si frente-libre entonces avanza;
          si frente-bloqueado entonces
          inicio
            mientras algun-zumbador-en-la-mochila hacer deja-zumbador;
            apagate;
          fin;
        fin;
      fin;
      repetir 2 veces gira-izquierda;
      mientras frente-libre hacer avanza;
      gira-izquierda;
      avanza;
      gira-izquierda;
    fin;
        apagate;
    termina-ejecucion
finalizar-programa
Si desea donar:

Problemas

Atinale al Beeper...(6380)
01/08/2011
Beeper o Castigo...(3769)
01/08/2011
La maldicion de los Beepe...(3742)
01/08/2011
Diez Avenidas con Vallas...(4406)
01/08/2011
Dividiendo segmentos...(3397)
01/08/2011
Ve por Leña...(4249)
01/08/2011
Karel en una Callejoneada...(3887)
01/08/2011
Karel Traviesa...(4268)
01/08/2011
Karel y Gretel...(5850)
01/08/2011
Karel y Gretel en la Feri...(4708)
01/08/2011

Fuentes

Las Escaleras...(96)
19/04/2021
Diez Avenidas con Vallas...(41)
16/04/2021
Vigas...(113)
14/04/2020
Vigas...(78)
14/04/2020
La moneda...(615)
22/07/2017
Primer fuente...(459)
13/10/2012
Fuente las escaleras...(476)
16/05/2012
Fuente Tumbando cabos...(289)
15/05/2012
Fuente Repartiendo...(335)
15/05/2012
Fuente La Torre...(429)
15/05/2012

.: Publicidad :.