.
Estadisticas ¿Karel? como instalar Uso Comandos Omijal Extras

El Emo

Descripción

Karel se ha hecho un Emo y no quiere estar con nadie y necesita encontrar un lugar completamente solo.

Problema

Ayuda a Karel encontrar una columna en donde no haya ningún zumbador.

Consideraciones

• Karel inicia en la posición 1,1, orientado hacia el norte.
• El mundo es cuadrado y no se sabe su tamaño.
• Habrá una columna en donde no haya ningún zumbador.
• Karel debe de terminar al final de la columna en donde no encontró zumbador.

Inicia en
y Termina
Ultimo fuente
Se emplean solo Ciclos
2012-04-29 00:00:00 am Leonardo
iniciar-programa
    inicia-ejecucion
    mientras frente-libre hacer
    inicio
      mientras no junto-a-zumbador y frente-libre hacer avanza;
      si frente-bloqueado y no junto-a-zumbador entonces apagate;
      repetir 2 veces gira-izquierda;
      mientras frente-libre hacer avanza;
      gira-izquierda;
      avanza;
      gira-izquierda;
    fin;
        apagate;
    termina-ejecucion
finalizar-programa
Si desea donar:

Problemas

Atinale al Beeper...(6562)
01/08/2011
Beeper o Castigo...(3901)
01/08/2011
La maldicion de los Beepe...(3911)
01/08/2011
Diez Avenidas con Vallas...(4639)
01/08/2011
Dividiendo segmentos...(3510)
01/08/2011
Ve por Leña...(4419)
01/08/2011
Karel en una Callejoneada...(4012)
01/08/2011
Karel Traviesa...(4429)
01/08/2011
Karel y Gretel...(6066)
01/08/2011
Karel y Gretel en la Feri...(4883)
01/08/2011

Fuentes

Las Escaleras...(112)
19/04/2021
Diez Avenidas con Vallas...(47)
16/04/2021
Vigas...(117)
14/04/2020
Vigas...(80)
14/04/2020
La moneda...(621)
22/07/2017
Primer fuente...(459)
13/10/2012
Fuente las escaleras...(500)
16/05/2012
Fuente Tumbando cabos...(290)
15/05/2012
Fuente Repartiendo...(335)
15/05/2012
Fuente La Torre...(431)
15/05/2012

.: Publicidad :.