.
Estadisticas ¿Karel? como instalar Uso Comandos Omijal Extras

La Bomba

Descripción

Un amigo de Karel le ha tirado una bomba Molotov a su jardín y Karel tiene que mandarla de regreso fuera de su jardín.

Problema

Ayuda a Karel a encontrar la bomba, llevarla fuera de su jardín y regresar a su casa.

Consideraciones

• Karel siempre inicia apuntando hacia el este.
• No se sabe donde cayó la bomba.
• No se sabe dónde está la barda de su jardín.
• La bomba está representada con un zumbador.
• Karel tiene que regresar a su casa al terminar la misión.
• No importa la orientación final de Karel.
• La bomba deberá dejarla en la fila 1 y en la columna inmediata posterior a la barda.
• La barda mide 1 metro de alto.

Inicia en
y Termina
Ultimo fuente
Ciclos y condicionantes
2012-04-29 00:00:00 am Leonardo
iniciar-programa
    inicia-ejecucion
    mientras frente-libre hacer
    inicio
      si junto-a-zumbador entonces coge-zumbador;
      avanza
    fin;
    si junto-a-zumbador entonces coge-zumbador;
    gira-izquierda;
    avanza;
    repetir 3 veces gira-izquierda;
    avanza;
    repetir 3 veces gira-izquierda;
    avanza;
    deja-zumbador;
    repetir 2 veces gira-izquierda;
    avanza;
    gira-izquierda;
    mientras frente-libre hacer avanza;
    gira-izquierda;
    avanza;
        apagate;
    termina-ejecucion
finalizar-programa
Si desea donar:

Problemas

Atinale al Beeper...(6562)
01/08/2011
Beeper o Castigo...(3901)
01/08/2011
La maldicion de los Beepe...(3911)
01/08/2011
Diez Avenidas con Vallas...(4639)
01/08/2011
Dividiendo segmentos...(3510)
01/08/2011
Ve por Leña...(4419)
01/08/2011
Karel en una Callejoneada...(4012)
01/08/2011
Karel Traviesa...(4429)
01/08/2011
Karel y Gretel...(6066)
01/08/2011
Karel y Gretel en la Feri...(4883)
01/08/2011

Fuentes

Las Escaleras...(112)
19/04/2021
Diez Avenidas con Vallas...(47)
16/04/2021
Vigas...(117)
14/04/2020
Vigas...(80)
14/04/2020
La moneda...(621)
22/07/2017
Primer fuente...(459)
13/10/2012
Fuente las escaleras...(500)
16/05/2012
Fuente Tumbando cabos...(290)
15/05/2012
Fuente Repartiendo...(335)
15/05/2012
Fuente La Torre...(431)
15/05/2012

.: Publicidad :.