.
Estadisticas ¿Karel? como instalar Uso Comandos Omijal Extras

La Bomba

Descripción

Un amigo de Karel le ha tirado una bomba Molotov a su jardín y Karel tiene que mandarla de regreso fuera de su jardín.

Problema

Ayuda a Karel a encontrar la bomba, llevarla fuera de su jardín y regresar a su casa.

Consideraciones

• Karel siempre inicia apuntando hacia el este.
• No se sabe donde cayó la bomba.
• No se sabe dónde está la barda de su jardín.
• La bomba está representada con un zumbador.
• Karel tiene que regresar a su casa al terminar la misión.
• No importa la orientación final de Karel.
• La bomba deberá dejarla en la fila 1 y en la columna inmediata posterior a la barda.
• La barda mide 1 metro de alto.

Inicia en
y Termina
Ultimo fuente
Ciclos y condicionantes
2012-04-29 00:00:00 am Leonardo
iniciar-programa
    inicia-ejecucion
    mientras frente-libre hacer
    inicio
      si junto-a-zumbador entonces coge-zumbador;
      avanza
    fin;
    si junto-a-zumbador entonces coge-zumbador;
    gira-izquierda;
    avanza;
    repetir 3 veces gira-izquierda;
    avanza;
    repetir 3 veces gira-izquierda;
    avanza;
    deja-zumbador;
    repetir 2 veces gira-izquierda;
    avanza;
    gira-izquierda;
    mientras frente-libre hacer avanza;
    gira-izquierda;
    avanza;
        apagate;
    termina-ejecucion
finalizar-programa
Si desea donar:

Problemas

Atinale al Beeper...(5832)
01/08/2011
Beeper o Castigo...(3515)
01/08/2011
La maldicion de los Beepe...(3353)
01/08/2011
Diez Avenidas con Vallas...(3938)
01/08/2011
Dividiendo segmentos...(3151)
01/08/2011
Ve por Leña...(3879)
01/08/2011
Karel en una Callejoneada...(3592)
01/08/2011
Karel Traviesa...(3940)
01/08/2011
Karel y Gretel...(5265)
01/08/2011
Karel y Gretel en la Feri...(4304)
01/08/2011

Fuentes

Las Escaleras...(64)
19/04/2021
Diez Avenidas con Vallas...(28)
16/04/2021
Vigas...(80)
14/04/2020
Vigas...(59)
14/04/2020
La moneda...(592)
22/07/2017
Primer fuente...(456)
13/10/2012
Fuente las escaleras...(466)
16/05/2012
Fuente Tumbando cabos...(282)
15/05/2012
Fuente Repartiendo...(327)
15/05/2012
Fuente La Torre...(420)
15/05/2012

.: Publicidad :.