.
Estadisticas ¿Karel? como instalar Uso Comandos Omijal Extras

La Bomba 2

Descripción

A Karel le volvieron a tirar una bomba, pero ahora le tiraron varias y no sabe donde cayeron.

Problema

Ayuda a Karel a encontrar las bombas, llevarlas fuera de su jardín y regresar a su casa.

Consideraciones

• Karel siempre inicia apuntando hacia el este.
• No se sabe donde cayeron las bombas.
• Solo puede haber una bomba por posición.
• No se sabe dónde está la barda de su jardín.
• No se sabe que tan alta es la barda.
• Las bombas están representadas con un zumbador.
• La bomba deberá dejarla en la fila 1 y en la columna inmediata posterior a la barda.
• Karel tiene que regresar a su posición original.
• No importa la orientación final de Karel.

Inicia en
y Termina
Ultimo fuente
Condiciones y ciclos
2012-04-29 00:00:00 am Leonardo
iniciar-programa
    inicia-ejecucion
    mientras frente-libre hacer
    inicio
      si junto-a-zumbador entonces coge-zumbador;
      avanza;
    fin;
    si junto-a-zumbador entonces coge-zumbador;
    gira-izquierda;
    mientras derecha-bloqueada hacer avanza;
    repetir 3 veces gira-izquierda;
    avanza;
    repetir 3 veces gira-izquierda;
    mientras frente-libre hacer avanza;
    mientras algun-zumbador-en-la-mochila hacer deja-zumbador;
    repetir 2 veces gira-izquierda;
    mientras izquierda-bloqueada hacer avanza;
    gira-izquierda;
    mientras frente-libre hacer avanza;
    gira-izquierda;
    mientras frente-libre hacer avanza;
        apagate;
    termina-ejecucion
finalizar-programa
Si desea donar:

Problemas

Atinale al Beeper...(5832)
01/08/2011
Beeper o Castigo...(3515)
01/08/2011
La maldicion de los Beepe...(3353)
01/08/2011
Diez Avenidas con Vallas...(3938)
01/08/2011
Dividiendo segmentos...(3152)
01/08/2011
Ve por Leña...(3879)
01/08/2011
Karel en una Callejoneada...(3592)
01/08/2011
Karel Traviesa...(3940)
01/08/2011
Karel y Gretel...(5265)
01/08/2011
Karel y Gretel en la Feri...(4305)
01/08/2011

Fuentes

Las Escaleras...(64)
19/04/2021
Diez Avenidas con Vallas...(28)
16/04/2021
Vigas...(80)
14/04/2020
Vigas...(59)
14/04/2020
La moneda...(592)
22/07/2017
Primer fuente...(456)
13/10/2012
Fuente las escaleras...(466)
16/05/2012
Fuente Tumbando cabos...(282)
15/05/2012
Fuente Repartiendo...(327)
15/05/2012
Fuente La Torre...(420)
15/05/2012

.: Publicidad :.