.
Estadisticas ¿Karel? como instalar Uso Comandos Omijal Extras

La Liga

Descripción

Karel tiene la misión de encontrar una pared que está enfrente, marcarla con un zumbador y regresar a su lugar.

Problema

Ayuda a Karel a encontrar la pared, dejar un zumbador junto a la pared y regresar a su posición original

Consideraciones

• Karel inicia apuntando hacia una pared.
• No se conoce la distancia entre la pared y Karel.
• No hay obstáculos entre la pared y Karel.
• Karel tendrá que dejar un zumbador junto a la pared.
• No importa la orientación final de Karel, solo su posición.

Inicia en
y Termina
Ultimo fuente
Recursividad, Condiciones y Ciclos
2012-04-29 00:00:00 am Leonardo
iniciar-programa
define-nueva-instruccion regreso como
inicio
  si frente-libre entonces
  inicio
    avanza;
    regreso
  fin
  sino
    repetir 2 veces gira-izquierda;
  avanza;
fin;
    inicia-ejecucion
        regreso;
        repetir 2 veces gira-izquierda;
        avanza;
        apagate;
    termina-ejecucion
finalizar-programa
Si desea donar:

Problemas

Atinale al Beeper...(5832)
01/08/2011
Beeper o Castigo...(3515)
01/08/2011
La maldicion de los Beepe...(3353)
01/08/2011
Diez Avenidas con Vallas...(3938)
01/08/2011
Dividiendo segmentos...(3151)
01/08/2011
Ve por Leña...(3879)
01/08/2011
Karel en una Callejoneada...(3592)
01/08/2011
Karel Traviesa...(3940)
01/08/2011
Karel y Gretel...(5265)
01/08/2011
Karel y Gretel en la Feri...(4304)
01/08/2011

Fuentes

Las Escaleras...(64)
19/04/2021
Diez Avenidas con Vallas...(28)
16/04/2021
Vigas...(80)
14/04/2020
Vigas...(59)
14/04/2020
La moneda...(592)
22/07/2017
Primer fuente...(456)
13/10/2012
Fuente las escaleras...(466)
16/05/2012
Fuente Tumbando cabos...(282)
15/05/2012
Fuente Repartiendo...(327)
15/05/2012
Fuente La Torre...(420)
15/05/2012

.: Publicidad :.