.
Estadisticas ¿Karel? como instalar Uso Comandos Omijal Extras

El Cuarto

Descripción

Karel está atrapado en un cuarto y no encuentra la puerta. Karel necesita salir del cuarto para poder ir a visitar a su novia Gretel.

Problema

Ayuda a Karel a encontrar la puerta de salida del cuarto oscuro y que se salga.

Consideraciones

• Karel siempre empieza pegado a una de las paredes del cuarto y se mueve en contra de las manecillas del reloj.
• El cuarto siempre es rectangular o cuadrado.
• No se sabe en qué posición esta la puerta.
• No existen obstáculos de por medio.
• Karel debe finalizar afuera del cuarto sin importar su orientación final.

Inicia en
y Termina
Ultimo fuente
Solo se emplean Ciclos
2012-04-29 00:00:00 am Leonardo
iniciar-programa
    inicia-ejecucion
    mientras derecha-libre hacer gira-izquierda;
    mientras frente-bloqueado hacer gira-izquierda;
    mientras derecha-bloqueada hacer
    inicio
      mientras frente-libre y derecha-bloqueada hacer avanza;
      si frente-bloqueado entonces gira-izquierda;
    fin;
    repetir 3 veces gira-izquierda;
    avanza;
        apagate;
    termina-ejecucion
finalizar-programa
Si desea donar:

Problemas

Atinale al Beeper...(6562)
01/08/2011
Beeper o Castigo...(3901)
01/08/2011
La maldicion de los Beepe...(3911)
01/08/2011
Diez Avenidas con Vallas...(4639)
01/08/2011
Dividiendo segmentos...(3510)
01/08/2011
Ve por Leña...(4419)
01/08/2011
Karel en una Callejoneada...(4012)
01/08/2011
Karel Traviesa...(4429)
01/08/2011
Karel y Gretel...(6066)
01/08/2011
Karel y Gretel en la Feri...(4883)
01/08/2011

Fuentes

Las Escaleras...(112)
19/04/2021
Diez Avenidas con Vallas...(47)
16/04/2021
Vigas...(117)
14/04/2020
Vigas...(80)
14/04/2020
La moneda...(621)
22/07/2017
Primer fuente...(459)
13/10/2012
Fuente las escaleras...(500)
16/05/2012
Fuente Tumbando cabos...(290)
15/05/2012
Fuente Repartiendo...(335)
15/05/2012
Fuente La Torre...(431)
15/05/2012

.: Publicidad :.