.
Estadisticas ¿Karel? como instalar Uso Comandos Omijal Extras

Diez Avenidas con Vallas

Descripción

Karel se encuentra en una competencia de carrera. Es necesario que recorra un camino que tiene vallas (obstáculos) hasta llegar al final donde se encuentra un beeper. Por lo tanto, es necesario que recorra la pista despegándose lo menos posible del piso. Problema Has un programa que lleve a Karel desde su punto inicial hasta la avenida que contiene un beeper.

Problema

 

Consideraciones

• Karel inicia siempre al principio de la pista mirando al Este (dirección a la que corre) y pegado a la derecha.
• Karel siempre debe ir lo más apegado que pueda a la pared derecha.
• Las vallas siempre tiene están sobre las avenidas (verticales), son de longitud uno y no hay dos que estén en avenidas consecutivas.
• El número de vallas no esta determinado (no puedes saber cual es la configuración de las vallas).
• La longitud de la pista no esta determinada.
• La carrera termina cuando llega a un beeper.

Inicia en
y Termina
Ultimo fuente
Código
2021-04-16 11:56:16 am EmilioLeon24
iniciar-programa
     define-nueva-instruccion sube como
       inicio
        gira-izquierda;
      mientras derecha-bloqueada y frente-libre y no junto-a-zumbador hacer
       inicio
        avanza;
     fin;
    fin;
      define-nueva-instruccion baja como
              inicio
         repetir 3 veces inicio
            gira-izquierda;
         fin;
      avanza;
        repetir 3 veces inicio
          gira-izquierda;
      fin;
        avanza;
      mientras derecha-bloqueada y frente-libre y no junto-a-zumbador hacer
        inicio
        avanza;
     si frente-bloqueado y no orientado-al-este entonces
      inicio
       gira-izquierda;
   fin;
 fin;
fin;
     define-nueva-instruccion hazlo como
       inicio
     mientras no-junto-a-zumbador y derecha-bloqueada y frente-libre hacer
        inicio
          avanza;
     mientras frente-bloqueado hacer
        inicio
           sube;
        mientras derecha-libre y frente-libre hacer
          inicio
             baja;
        fin;
       fin;
      fin;
    fin;
    inicia-ejecucion
      hazlo;
        apagate;
    termina-ejecucion
finalizar-programa
Si desea donar:

Problemas

Atinale al Beeper...(5705)
01/08/2011
Beeper o Castigo...(3480)
01/08/2011
La maldicion de los Beepe...(3327)
01/08/2011
Diez Avenidas con Vallas...(3913)
01/08/2011
Dividiendo segmentos...(3125)
01/08/2011
Ve por Leña...(3841)
01/08/2011
Karel en una Callejoneada...(3524)
01/08/2011
Karel Traviesa...(3904)
01/08/2011
Karel y Gretel...(5191)
01/08/2011
Karel y Gretel en la Feri...(4205)
01/08/2011

Fuentes

Las Escaleras...(63)
19/04/2021
Diez Avenidas con Vallas...(28)
16/04/2021
Vigas...(80)
14/04/2020
Vigas...(59)
14/04/2020
La moneda...(590)
22/07/2017
Primer fuente...(456)
13/10/2012
Fuente las escaleras...(466)
16/05/2012
Fuente Tumbando cabos...(282)
15/05/2012
Fuente Repartiendo...(327)
15/05/2012
Fuente La Torre...(418)
15/05/2012

.: Publicidad :.