.
Estadisticas ¿Karel? como instalar Uso Comandos Omijal Extras

Secuestro

Descripción

Karel está enojado con Aldo, un compañero de clase, porque le volteó su mochila entonces ha planeado un secuestro.

Problema

Ayuda a Karel a secuestrar a Aldo para que aprenda de no meterse con él. Encuentra a Aldo y secuéstralo (rodéalo con zumbadores).

Consideraciones

• No se sabe donde inicia Karel.
• El mundo es rectangular o cuadrado y no tiene obstaculos adentro.
• No importa donde termine Karel.
• Aldo es representado por un montón de 2 zumbadores.
• Tienes que rodear a Aldo con montones de 1 zumbador.
• Aldo ha superado su fobia por las paredes y ahora si puede estar pegado a ellas.
• Karel tiene 8 zumbadores en la mochila.

Inicia en
y Termina
Ultimo fuente
Ciclos y condiciones
2012-05-03 00:00:00 am Leonardo
iniciar-programa
    inicia-ejecucion
    mientras no orientado-al-oeste hacer gira-izquierda;
    mientras frente-libre hacer avanza;
    gira-izquierda;
    mientras frente-libre hacer avanza;
    gira-izquierda;
    mientras frente-libre hacer
    inicio
      mientras no junto-a-zumbador y frente-libre hacer avanza;
      si junto-a-zumbador entonces
      inicio
        repetir 4 veces
        inicio
          si frente-libre entonces
          inicio
            avanza;
            si no junto-a-zumbador entonces deja-zumbador;
            gira-izquierda;
            si frente-libre entonces
            inicio
              avanza;
              si no junto-a-zumbador entonces deja-zumbador;
              repetir 2 veces gira-izquierda;
              avanza;
              repetir 2 veces gira-izquierda;
            fin;
            gira-izquierda;
            avanza;
            repetir 2 veces gira-izquierda;
          fin;
          gira-izquierda;
        fin;
        apagate;
      fin;
      si frente-bloqueado entonces
      inicio
        repetir 2 veces gira-izquierda;
        mientras frente-libre hacer avanza;
        repetir 3 veces gira-izquierda;
        avanza;
        repetir 3 veces gira-izquierda;
      fin;
    fin;
        apagate;
    termina-ejecucion
finalizar-programa
Si desea donar:

Problemas

Atinale al Beeper...(5948)
01/08/2011
Beeper o Castigo...(3570)
01/08/2011
La maldicion de los Beepe...(3522)
01/08/2011
Diez Avenidas con Vallas...(3996)
01/08/2011
Dividiendo segmentos...(3202)
01/08/2011
Ve por Leña...(3945)
01/08/2011
Karel en una Callejoneada...(3663)
01/08/2011
Karel Traviesa...(3997)
01/08/2011
Karel y Gretel...(5348)
01/08/2011
Karel y Gretel en la Feri...(4391)
01/08/2011

Fuentes

Las Escaleras...(67)
19/04/2021
Diez Avenidas con Vallas...(30)
16/04/2021
Vigas...(80)
14/04/2020
Vigas...(61)
14/04/2020
La moneda...(593)
22/07/2017
Primer fuente...(456)
13/10/2012
Fuente las escaleras...(467)
16/05/2012
Fuente Tumbando cabos...(282)
15/05/2012
Fuente Repartiendo...(327)
15/05/2012
Fuente La Torre...(422)
15/05/2012

.: Publicidad :.