.
Estadisticas ¿Karel? como instalar Uso Comandos Omijal Extras

Mundo Loco

Descripción

 

Problema

Karel tiene que agregar un zumbador a los montones de 1 zumbador que encuentre y restarle 1zumbador a los montones de 2 zumbadores que encuentre.

Consideraciones

• El mundo es cuadrado.
• Karel inicia en algún lugar del mundo apuntando hacia cualquier lado.
• Karel inicia con infinitos zumbadores en la mochila.
• No importa donde termine Karel.

Inicia en
y Termina
Ultimo fuente
Ciclos y Condiciones, muy bueno para practicar la logica del alumnos
2012-05-03 00:00:00 am Leonardo
iniciar-programa
    inicia-ejecucion
    mientras no orientado-al-norte hacer gira-izquierda;
    mientras frente-libre hacer avanza;
    gira-izquierda;
    mientras frente-libre hacer avanza;
    repetir 2 veces gira-izquierda;
    mientras frente-libre hacer
    inicio
      mientras no junto-a-zumbador y frente-libre hacer avanza;
      si junto-a-zumbador entonces
      inicio
        si junto-a-zumbador entonces coge-zumbador;
        si no junto-a-zumbador entonces repetir 2 veces deja-zumbador;
      fin;
      si frente-libre entonces avanza;
      si frente-bloqueado entonces
      inicio
        repetir 2 veces gira-izquierda;
        mientras frente-libre hacer avanza;
        gira-izquierda;
        si frente-bloqueado entonces apagate;
        avanza;
        gira-izquierda;
      fin;
    fin;
        apagate;
    termina-ejecucion
finalizar-programa
Si desea donar:

Problemas

Atinale al Beeper...(5947)
01/08/2011
Beeper o Castigo...(3569)
01/08/2011
La maldicion de los Beepe...(3522)
01/08/2011
Diez Avenidas con Vallas...(3996)
01/08/2011
Dividiendo segmentos...(3202)
01/08/2011
Ve por Leña...(3945)
01/08/2011
Karel en una Callejoneada...(3663)
01/08/2011
Karel Traviesa...(3996)
01/08/2011
Karel y Gretel...(5347)
01/08/2011
Karel y Gretel en la Feri...(4391)
01/08/2011

Fuentes

Las Escaleras...(67)
19/04/2021
Diez Avenidas con Vallas...(30)
16/04/2021
Vigas...(80)
14/04/2020
Vigas...(61)
14/04/2020
La moneda...(593)
22/07/2017
Primer fuente...(456)
13/10/2012
Fuente las escaleras...(467)
16/05/2012
Fuente Tumbando cabos...(282)
15/05/2012
Fuente Repartiendo...(327)
15/05/2012
Fuente La Torre...(422)
15/05/2012

.: Publicidad :.